As any other product, ODE has versions. Different ODE versions could be significantly different. We have restructured ODE Config database once and we could do it again as we constantly improving ODE.

We have created a number of useful helper scripts. They do all the hard work behind the scenes, you only need to provide parameters to configure your Data Vault in the way you want. Due to difference in database structure between the versions, helper script version should match the ODE Config version.

So, how do you know what’s your current version of ODE? Look for the table under the ODE_Release schema in your ODE_Config database. There will be just one table. Its name is your ODE version.

E.g. this is ODE version 4.1.1 Use helper scripts for ODE v4. Scripts for ODE v2 or other versions will not work with this version.